$re = '/(?:^|[^\S\n])([a-z]\d)(?!\S)/im';
$str = 'aa
a2
a1
d4
fg4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);