package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4},)+$`)
var str = `abc@gmail.com,abc@gmail.com,,,,,,,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,abc@gmail.com,.!@!@##!@#!@#..0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}