import re
regex = re.compile(r"\A(?:(?!^SA21 abcdef$).)*(^SA21 abcdef$)(?:(?!^SA21 abcdef$).)*\z", flags=re.MULTILINE | re.DOTALL)
test_str = ("Line 1\n"
"SA21 abcdef\n"
"BKxyz\n"
"SA22 abcdef")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")