re = /^[a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+@[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)+$/m
str = '# this doesn\'t match
example@example
# this one matches instead
example@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end