$re = '/-?\d+\.?\d+/m';
$str = 'a12b-13c12.0d-12 ...... 546e1222.001f23.g33h23..254';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);