re = /^[a-zA-ZÀ-ÿ\u00f1\u00d1]+(\s*[a-zA-ZÀ-ÿ\u00f1\u00d1]*)*[a-zA-ZÀ-ÿ\u00f1\u00d1]+$/
str = 'Juan Álvarez'
# Print the match result
str.match(re) do |match|
puts match.to_s
end