import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n"
+ "# allow multiple groups with the same name\n"
+ "(?J)\n"
+ "# protocol user host-ip port path path path querystring fragment\n"
+ "^\n"
+ "#protocol\n"
+ "(?:(?<scheme>[a-zA-Z][a-zA-Z\\d+-.]*):)?\n"
+ "(?|\n"
+ " #slash-slash\n"
+ " \\/\\/\n"
+ " #userinfo\n"
+ " (?:\n"
+ " #user\n"
+ " (?<user>[a-zA-Z\\d\\-._~\\!$&'()*+,;=%]*)\n"
+ " #password\n"
+ " (?::(?<pass>[a-zA-Z\\d\\-._~\\!$&'()*+,;=:%]*))?\n"
+ " @)?\n"
+ " #host-ip\n"
+ " (?<host>(?:[a-zA-Z\\d-.%]+)|(?:\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})|(?:\\[(?:[a-fA-F\\d.:]+)\\]))?\n"
+ " #port\n"
+ " (?::(?<port>\\d*))?\n"
+ " #slash-path\n"
+ " (?<path>\n"
+ " (?:\\/ [a-zA-Z\\d\\-._~\\!$&'()*+,;=:@%]* )*\n"
+ " )\n\n"
+ " #slash-path\n"
+ " |(?<user>)(?<pass>)(?<host>)(?<port>)\n"
+ " (?<path>\\/ [a-zA-Z\\d\\-._~\\!$&'()*+,;=:@%]+(?:\\/[a-zA-Z\\d\\-._~\\!$&'()*+,;=:@%]*)*)?\n\n"
+ " #path\n"
+ " |(?<user>)(?<pass>)(?<host>)(?<port>)\n"
+ " (?<path> [a-zA-Z\\d\\-._~\\!$&'()*+,;=:@%]+(?:\\/[a-zA-Z\\d\\-._~\\!$&'()*+,;=:@%]*)*)\n\n"
+ ")?\n"
+ "#querystring\n"
+ "(?:\\?(?<query>[a-zA-Z\\d\\-._~\\!$&'()*+,;=:@%\\/?]*))?\n"
+ "#fragment\n"
+ "(?:\\#(?<fragment>[a-zA-Z\\d\\-._~\\!$&'()*+,;=:@%\\/?]*))?\n"
+ "$\n";
final String string = "https://regex101.com/\n"
+ "https://regex101.com/thing/blah.foo\n"
+ "https://regex101.com:28801/thing/blah/patterns?where_foo=bar&where_primary_access_node=true\n"
+ "https://regex101.com:8443/thing/index.html#/landing";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}