// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?(DEFINE)(?'dn'[^\\\/:*"<>|\ ]+[^\\\/:*"<>|]*[^\\\/:*"<>|\.\ ]+)(?'ds'\\|\/))(?'fn_path'(?'f_path'(?&ds)?((\.{1,2}(?&ds))|((?&dn)(?&ds)))*)?(?'fn'(?&dn)))(?'ext_dot'\.(?'ext'asm))$"#).unwrap();
let string = ".\\.\\../../../fil l/fill2.asm.asmfile.asm
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}