$re = '/(\w+|".*?(?<!\\\\)")/';
$str = 'This is "a string" and this is "a \\"nested\\" string"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);