$re = '/\b(?!\1)(\w)/i';
$str = 'Take all first words for each letter... this is a test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);