import re
regex = re.compile(r"""
\A\s*
(?: #########################################################################
# Option A: [<Addition to address 1>] <House number> <Street name> #
# [<Addition to address 2>] #
#########################################################################
(?:(?P<A_Addition_to_address_1>.*?),\s*)? # Addition to address 1
(?:No\.\s*)?
(?P<A_House_number_1>\pN+[a-zA-Z]?(?:\s*[-\/\pP]\s*\pN+[a-zA-Z]?)*) # Street name
\s*,?\s*
(?P<A_Street_name_1>(?:[a-zA-Z]\s*|\pN\pL{2,}\s\pL)\S[^,#]*?(?<!\s)) # House number
\s*(?:(?:[,\/]|(?=\#))\s*(?!\s*No\.)
(?P<A_Addition_to_address_2>(?!\s).*?))? # Addition to address 2
| #########################################################################
# Option B: [<Addition to address 1>] <Street name> <House number> #
# [<Addition to address 2>] #
#########################################################################
(?:(?P<B_Addition_to_address_1>.*?),\s*(?=.*[,\/]))? # Addition to address 1
(?!\s*No\.)(?P<B_Street_name>\S\s*\S(?:[^,#](?!\b\pN+\s))*?(?<!\s)) # House number
\s*[\/,]?\s*(?:\sNo\.)?\s+
(?P<B_House_number>\pN+\s*-?[a-zA-Z]?(?:\s*[-\/\pP]?\s*\pN+(?:\s*[\-a-zA-Z])?)*|[IVXLCDM]+(?!.*\b\pN+\b))(?<!\s) # Street name
\s*(?:(?:[,\/]|(?=\#)|\s)\s*(?!\s*No\.)\s*
(?P<B_Addition_to_address_2>(?!\s).*?))? # Addition to address 2
)
\s*\Z
""", flags=re.VERBOSE)
test_str = "Corso XXII Marzo 69"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")