using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*$(?<!\.txt)";
string input = @"happiness.html
joy.png
madness.html.txt
excitement.txt
fear.src";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}