import re
regex = re.compile(r"((?<=\()\S+(?=%\))|^\S+(?=\s\[))", flags=re.MULTILINE)
test_str = ("0\n"
"1991 (38.26%)\n"
"1018 (41.52%)\n"
"438 (35.12%)\n"
"771 (35.16%)\n"
"244 (35.72%)\n"
"343 (32.48%)\n"
"316 (40.51%)\n"
"177 (33.84%)\n"
"133 (41.18%)\n"
"792 (35.92%)\n"
"3190 (61.30%)\n"
"1426 (58.16%)\n"
"803 (64.39%)\n"
"1415 (64.52%)\n"
"436 (63.84%)\n"
"711 (67.33%)\n"
"463 (59.36%)\n"
"345 (65.97%)\n"
"187 (57.89%)\n"
"1403 (63.63%)\n"
"44.00 [38.00 - 50.00]\n"
"43.00 [37.00 - 49.00]\n"
"43.00 [37.00 - 49.00]\n"
"44.00 [38.00 - 50.00]\n"
"44.00 [39.00 - 50.00]\n"
"44.00 [38.00 - 50.00]\n"
"43.00 [37.00 - 49.00]\n"
"45.00 [39.00 - 51.00]\n"
"44.00 [37.00 - 50.00]\n"
"45.00 [38.00 - 51.00]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")