const regex = /^[^_A-Za-z]|.([^\p{Letter}0-9\-_]|[\s])/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^_A-Za-z]|.([^\\p{Letter}0-9\\-_]|[\\s])', 'u')
const str = `wdadù
-wdadw
_wdwdawd
23
_33454
.2435
now how
dww
test-now
àwdàawd
wad-àùùdw
test_ok`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}