$re = '/^cat.*?dog$/m';
$str = 'cat/1.39 bla, monkey dog
cat/1.39 bla, monkey dog
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);