$re = '/^(?!.*\bneeds info\b).+/m';
$str = 'filters for only *has* needs info label
filters for only *has* needs info label
foo bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);