import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(anime|manga|hentai|sex|xxx))(.+)$";
final String string = "127.0.0.1 www.animenewsnetwork.com www.animenewsnetwork.co.uk\n\n"
+ "127.0.0.1 watchseries.lt www.tv.com myanimelist.net www.crunchyroll.co.uk www.wikia.com www.anidb.net www.gogoanime.com \n\n"
+ "127.0.0.1 www.goodanime.net www.pinoyanime.tv www.animeultima.tv animewaffles.tv anilinkz.com www.animehere.com www.anime4fun.com www.animefreak.tv \n\n"
+ "127.0.0.1 www.animetake.com www.waoanime.tv waoanime.tv mangafox.me www.animeget.com www.animefushigi.com\n\n"
+ "127.0.0.1 www.crunchyroll.com vodlocker.com answers.yahoo.com www.animeultima.tv zeroanime.net\n\n"
+ "127.0.0.1 www.tv.com www.watchsnk.com www.sidereel.com www.adultswim.com video.adultswim.com www.solarmovie.tl\n\n"
+ "127.0.0.1 watch32.com www.kongregate.com www.roblox.com www.siliconera.com mmoculture.com www.mangawindow.com www.hulu.com\n\n"
+ "127.0.0.1 www.dualshockers.com www.madman.co.nz www.mangabb.me www.ovguide.com www.tvrage.com anime-odcinki.pl www.mangabird.com \n\n"
+ "127.0.0.1 attackontitan.blogspot.com www.yidio.com www.dubzonline.tv www.vanime.net soulskill.com www.agaleradosanimes.net www.tvmuse.com\n\n"
+ "127.0.0.1 www.anitube.se www.animestatic.com kotaku.com n4g.co www.animelite.net attackontitan.blogspot.com www.solarmovie.tl\n\n"
+ "127.0.0.1 www.mangatank.com www.nineanime.com mangadoom.com desene.tv www.graalians.com jkanime.net dynasty-scans.com\n\n"
+ "127.0.0.1 www.anime-stream24.net watchtvseries.to animetako.com www.gaiaonline.com megafilmeshd.net deseneanime.ro\n\n"
+ "127.0.0.1 www.animeforum.com www.veoh.com http://anime44.co.uk animesstream.com animetoplist.org aniver.se\n\n"
+ "127.0.0.1 letmewatchanime.com napisy.info www.animesfox-br.org www.letmewatchthis.ch vershingekinokyojin.com\n\n"
+ "127.0.0.1 www.videoweed.es www.novamov.com beta.miloyski.com www.2gb-hosting.com www.tomwans.com www.gigabyteupload.com\n\n"
+ "127.0.0.1 f1.ilivlite.com played.to www.vidbull.com watchseries.ag www.animefave.net www.animeseason.com www.gogoanime.com\n\n"
+ "127.0.0.1 www.animeplus.tv animewaffles.tv www.animeflavor.com www.animebox.tv www.anime44.com www.animehere.com www.soul-anime.net\n\n"
+ "127.0.0.1 anilinkz.com www.nwanime.com www.anime-sub.com www.centeranime.net www.animedose.net www.subbedanime.tv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}