re = /\<(\w+)\s[^>]*?style=([\"|\']).*?\2\s?[^>]*?(\/?)>/mi
str = ' div\' is a draw:frame.
--><div style="height:2.818cm;width:26.67cm; padding:0; " class="P9"><p><img src="" /></p></div><!--Next \'
div\' is a draw:frame.
--><div style="height:2.086cm;width:19.05cm; padding:0; " class="P9"><p><img src="" /></p></div><!--Next \'
div\' is a draw:frame.
--><div style="height:3.303cm;width:25.21cm; padding:0; " class="P9"><p><img src="" /></p></div><!--Next \'
div\' is a draw:frame.
--><div style="height:0.949cm;width:15.864cm; padding:0; " class="P9"><p><img src="" /></p></div></div><div style="clear:both; line-height:0; width:0; height:0; margin:0; padding:0;"> </div><!--Next \'div\' was a \'draw:page\'.--><div id="page5" class="dp3"> <!--Next \'
div\' is a draw:frame.
--><div style="height:3.255cm;width:25.197cm; padding:0; " class="P4"><!--Next \'div\' was a \'draw:text-box\'.--><div style=""><ol><li><p style="margin-left:0cm;"><span style="display:block;float:left;min-width:0cm"><!-- --></span>Account Performance YoY Revenue<span class="odfLiEnd"/> </p></li></ol></div></div><!--Next \'
div\' is a draw:frame.
--><div style="height:5.715cm;width:24.306cm; padding:0; " class="P9"><p><img src="" /></p></div><!--Next \'
div\' is a draw:frame.
--><div style="height:4.251cm;width:24.13cm; padding:0; " class="P9"><p><img src="" /></p></div></div><div style="clear:both; line-height:0; width:0; height:0; margin:0; padding:0;"> </div><!--Next \'div\' was a \'draw:page\'.--><div id="page6" class="dp3"> <!--Next \'
div\' is a draw:frame.
--><div style="height:1.839cm;width:25.197cm; padding:0; " class="P4"><!--Next \'div\' was a \'draw:text-box\'.--><div style=""><ol><li><p style="margin-<span style="display:block;float:left;min-width:0cm"><!-- --></span>Top Level Statistics - YTD<span class="odfLiEnd"/> </p></li></ol></div></div><!--Next \'
div\' is a draw:frame.
--><div style="height:17.145cm;width:25.197cm; padding:0; " class="P4"><!--Next \'div\' was a \'draw:text-box\'.--><div style=""><ol><li><p style="margin-left:0cm;"><span style="display:block;float:left;min-width:0cm"><!-- --></span>Total Campaigns (all): 40<span class="odfLiEnd"/> </p></li><li><p style="margin-left:0cm;"><span style="display:block;float:left;min-width:0cm"><!-- --></span>Total Ad Groups: 107<span class="odfLiEnd"/> </p></li><li><p style="margin-left:0cm;"><span style="display:block;float:left;min-width:0cm"><!-- --></span>Top Performing Campaigns ROI<span class="odfLiEnd"/> </p></li></ol><ul><li><ol><li><p style="margin-left:0cm;"><span style="display:block;float:left;min-width:0cm"><!-- --></span>GSN Orchid Brand: $11,491.30, Yield $149,532 (ROI = 1300%)<span class="odfLiEnd"/> </p></li><li><p style="margin-left:0cm;"><spa'
subst = '<$1$3>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result