const regex = /(?:\.\d+|\b\d+(?:\.\d+)?)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\.\\d+|\\b\\d+(?:\\.\\d+)?)\\b', 'g')
const str = `.1 this is a1 my test 1a 12 string 12.123 whatever 1 20.42word`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}