package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\/\/\/.*<summary>.*<\/summary>`)
var str = `/// <summary>
///
/// </summary>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}