using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@""^([\u00c0-\u01ffa-zA-Z'\-])+$""";
string input = @"aaa1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}