$re = '/id=\'([^\']*)\'/';
$str = 'id=\'id1\' or id=\'id2\' or id=\'id3\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);