package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w-]*-@-[\w-]*\.[\w-]*`)
var str = `a-b-c-@-d-e-.-e-f-g`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}