import re
regex = re.compile(r"""
(?(DEFINE)
(?<int>
(?:
\G|
(?!\n)
)
\s*\b\d{1,5}\s*
)
(?<timepart>
(
s|
m|
h|
d
)
\b
)
)
^
((?&int))
((?&timepart))
(?<string>.+)
$
""", flags=re.VERBOSE | re.IGNORECASE | re.MULTILINE)
test_str = ("2min baz\n"
"12 mins foo\n"
"1 hour 20 mins remind this\n"
"1sec\n"
"5 hours\n"
"1 sec foo\n"
"3 minutes 4 seconds\n"
"3333 sec do\n"
"1 hrs 20 mins 5 seconds remind this\n"
"2 days 3 hrs 20 mins 5 seconds remind this\n"
"foo 2sec bar //fail\n"
"2 s hi\n"
"3 m foo\n"
"3m bar\n"
"2d baz\n"
"9 h foobar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")