re = /<name="[^"]*">|([_!=+])/m
str = 'cat_dog_ !mouse= <name="Jake_Russell!"> gog+cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end