$re = '/\$\d+\.\d{2}(?!\d)/m';
$str = '$19.48
$1234.2312
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);