package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-azA-Z]{1,3}\d{4,10}$|^\d{4,10}[a-zA-Z]{1,2}\d?$|\b[1-9][AC-HJKMNP-RT-Yac-hjkmnp-rt-y][AC-HJKMNP-RT-Yac-hjkmnp-rt-y0-9][0-9]-?[AC-HJKMNP-RT-Yac-hjkmnp-rt-y][AC-HJKMNP-RT-Yac-hjkmnp-rt-y0-9][0-9]-?[AC-HJKMNP-RT-Yac-hjkmnp-rt-y]{2}\d{2}\b`)
var str = `examples, these go line by line
ABCD123456ABC
abc
does not match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}