re = /<\/?code>/
str = 'No <code>for</code>, o valor de <code>i</code> começa de zero e é incrementado a cada volta enquanto <code>i < 10</code>, portando o bloco de código do for é executado 10 vezes.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end