$re = '/((?:[a-zA-Z0-9\+\/]{4}){4,}(?:[a-zA-Z0-9\+\/]{0,3}\={1,3})?)/';
$str = 'This is a randomly base64 string in a text PHNjcmlwdD5hbGVydCgiaHR0cHM6Ly9naXRodWIuY29tL0RheGRhL3JlZ2V4U25pcHBldHMvIik8L3NjcmlwdD4= or is it?
<script>eval(atob("YWxlcnQoIkV2YWwgaXMgZXZpbCIp"))</script>
U28gZG9lcyBteSBzaGVsbA===
UHl0aG9uIGlzIGF3ZXNvbWU=
TGludXggYXN3ZWxs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);