re = /^(?:[0-1][1-2])\/(?:[0-2]\d|3[0-1])$/m
str = '01/31
01/28
01/05
01/32
01/41'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end