const regex = new RegExp('(?P<first_part>(?:ifstream|ofstream)\\s+[0-9a-zA-z_]+\\s*\\()(?:\\"(?P<file_name>[0-9a-zA-z_.]+)\\")', 'g')
const str = `ifstream f1("text1.txt");
ifstream f2 ("text2.txt");
ifstream f_ASFdf1("text1");
ofstream out ("output.txt");//создали объект и сразу же открыли файл для записи
ofstream of;//создали объект класса
of.open("test.txt");//открыли файл для записи
ofstream of("test.txt", ios_base::app); //добавление информации к концу файла
ofstream of("test.txt", ios_base::trunc); //очистить содержимое файла
ofstream of("test.txt", ios_base::binary); //открыть в бинарном режиме`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}