re = /"(.*)"/
str = '"THREAD1" daemon prio=10 tid=0x00007ff6a8007000 nid=0xd4b6 runnable [0x00007ff7f8aa0000]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end