package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(.*?)"`)
var str = `"THREAD1" daemon prio=10 tid=0x00007ff6a8007000 nid=0xd4b6 runnable [0x00007ff7f8aa0000]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}