re = /(?s)^(?=[^1]*1)(?=[^2]*2)(?=[^3]*3)(?=[^4]*4)(?=[^5]*5)(?=[^6]*6)(?=[^7]*7)(?=[^8]*8)(?=[^9]*9)(?=[^0]*0).*$/
str = 'ew12-33-54-67890dde'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end