import re
regex = re.compile(r"^(.+?)\ *=\ *(.*)", flags=re.MULTILINE)
test_str = ("#INFOFILE1.1 - Do not remove this line!\n"
"FileIdent = CarMaker-Plugins 1\n"
"FileCreator = CarMaker 2014-12-18 08:00:00\n\n\n"
"## Plugins #############################################################\n"
"VehicleControl.ZMS = 1\n"
"VehicleControl.ZMS.Info = ZMS\n"
"Brake.MyBrake_FMU = 1\n"
"Brake.MyBrake_FMU.Info = MyBrake_FMU\n"
"PTClutch.MyClutch_FMU = 1\n"
"PTClutch.MyClutch_FMU.Info = MyClutch_FMU\n"
"VehicleControl.MyVehicleControl_FMU = 1\n"
"VehicleControl.MyVehicleControl_FMU.Info = MyVehicleControl_FMU")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")