$re = '/\([^\]]*\)|(&&)/m';
$str = '{f1} == v1 && {f2} == v2 && ({f3} == v3 && {f4} == v4) && {f5} == v5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);