re = /(?<=[0-9]{4}\/[0-9]{2}\/[0-9]{2})(.)+|(.)+(?=[0-9]{4}\/[0-9]{2}\/[0-9]{2})/m
str = 'x 1999/31/12 x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end