import re
regex = re.compile(r"(\+97[\s]{0,1}[\-]{0,1}[\s]{0,1}1|0)50[\s]{0,1}[\-]{0,1}[\s]{0,1}[1-9]{1}[0-9]{6}")
test_str = ("Matches (mobile)\n"
"+97150 3827741 | 0503827741 | 050-3827741\n"
"Non-Matches \n"
"040 3827741 | 05 3827741 | 050_______spaces_______3827741\n\n"
"Matches (land)\n"
"04 3452488 | 04 -3452488 | 04 - 3452499\n"
"Non-Matches \n"
"01 -3452488 | 04 34524888 | 04 3452488\n\n"
"Other tests\n"
"+97150 3827741 | +97150 3827741")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")