re = /^(?!.*[ ]{2})(?!.*[']{2})(?!.*[-]{2})(?:[a-zA-Z0-9 \:\/\p{L}'-]{1,64}$)$/m
str = 'Some Name
Another Name
This should fail
So should this'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end