$re = '/\b\w+\(/';
$str = 'a = func(a + func2(func3(c)+4));
hello();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);