package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)[a-zA-Z0-9!"#%()*+ -.\/=?_ ]*`)
var str = `Hao 123 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}