# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[0-9]+(?:\.[0-9]+){3}"
test_str = ("Gateway of last resort is 10.119.254.240 to network 10.140.0.0 \n"
"O E2 10.110.0.0 [160/5] via 10.119.254.6, 0:01:00, Ethernet2\n"
"D 10.67.10.0 [200/128] via 10.119.254.244, 0:02:22, Ethernet2\n"
"O E2 10.68.132.0 [160/5] via 10.119.254.6, 0:00:59, Ethernet2")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.