re = /(.)(?!.*\1)(.)\2{2}(?!\2{1,4})(.)\3{1}(?!\3{1,2})(.)\4{1}/m
str = '01110033
ABBBCCDD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end