$re = '/^(?!.*(.)(.)\2\1).+$/m';
$str = 'Match:
aesthophysiology
amphimictical
baruria
calomorphic
Don\'t Match
anallagmatic
bassarisk
chorioallantois
coccomyces
abba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);