re = /(?<![A-Za-z0-9])(?=[A-Za-z]*[0-9][A-Za-z0-9]*)[A-Za-z0-9]{6,}/
str = 'abcd12'
# Print the match result
str.match(re) do |match|
puts match.to_s
end