import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RequestParam *\\( *value *= *\"[^\"\\n]*[A-Z][^\"\\n]*\"";
final String string = " public Response searchA(@RequestParam(value = \"_s\", required = true) String searchExpression,\n"
+ " public Response getNumber(@RequestParam(value = \"someNumber\", required = true) String agencyNumber,\n"
+ " public Response getStuff(@PathVariable(\"id\") String asnId, @RequestParam(value = \"customerid\") String customerId, \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}