package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+),?`)
var str = `aa,bb,cc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}