$re = '~(?<=[^/\n].)/(?=.[^/\n])~m';
$str = 'xx/xx/xxyy/ZZZ
x/x
/x/x/x/xxx/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);