$re = '/^[A-Z]{3}$/m';
$str = 'LGW
LGWE
LG!@
12L
ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);