$re = '/\*(~[0-9]{2}\s?)/';
$str = '*~2
*~20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);